RoboVM plugin is disabled

Anything libgdx related goes here!

RoboVM plugin is disabled

Postby a11an » Thu Jan 16, 2020 3:23 pm

I hope someone can offer some advice, I'm really stuck :cry: :cry:

I am trying to update my older games, as Apple has asked me to update them otherwise they will be removed. When I open an old app (or create a new project using the latest Libgdx Project Generator) I get the error below and the RoboVM plugin is disabled. I am using the latest version of IntelliJ IDEA 2019.3.

Any ideas? thanks for looking.

Code: Select all
Plugin 'com.mobidevelop.robovm.intellij' failed to initialize and will be disabled.  Please restart IntelliJ IDEA.

java.lang.NoClassDefFoundError: com/intellij/pom/java/LanguageLevel
    at org.robovm.idea.sdk.RoboVmSdkType.<clinit>(RoboVmSdkType.java:39)
    at org.robovm.idea.components.RoboVmApplicationComponent.displaySetupWizard(RoboVmApplicationComponent.java:60)
    at org.robovm.idea.components.RoboVmApplicationComponent.initComponent(RoboVmApplicationComponent.java:50)
    at com.intellij.serviceContainer.MyComponentAdapter.doCreateInstance(MyComponentAdapter.kt:42)
    at com.intellij.serviceContainer.BaseComponentAdapter.getInstanceUncached(BaseComponentAdapter.kt:110)
    at com.intellij.serviceContainer.BaseComponentAdapter.getInstance(BaseComponentAdapter.kt:72)
    at com.intellij.serviceContainer.BaseComponentAdapter.getInstance$default(BaseComponentAdapter.kt:65)
    at com.intellij.serviceContainer.PlatformComponentManagerImpl.createComponents(PlatformComponentManagerImpl.kt:177)
    at com.intellij.openapi.application.impl.ApplicationImpl.lambda$loadComponents$3(ApplicationImpl.java:346)
    at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(CoreProgressManager.java:163)
    at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:585)
    at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:531)
    at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:59)
    at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:150)
    at com.intellij.openapi.application.impl.ApplicationImpl.loadComponents(ApplicationImpl.java:346)
    at com.intellij.idea.ApplicationLoader$startApp$6$loadComponentInEdtFuture$1.run(ApplicationLoader.kt:206)
    at java.base/java.util.concurrent.CompletableFuture$AsyncRun.run(CompletableFuture.java:1736)
    at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
    at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:776)
    at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:727)
    at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
    at java.base/java.security.AccessController.doPrivileged(Native Method)
    at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
    at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:746)
    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:398)
    at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
    at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
    at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
    at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
    at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Caused by: java.lang.ClassNotFoundException: com.intellij.pom.java.LanguageLevel
    at com.intellij.util.lang.UrlClassLoader.findClass(UrlClassLoader.java:307)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    ... 31 more
a11an
 
Posts: 19
Joined: Wed May 18, 2016 12:16 pm
Location: London

Re: RoboVM plugin is disabled

Postby shatterblast » Thu Jan 16, 2020 4:41 pm

You probably need to make sure your RoboVM version is 2.3.7 and your LibGDX version is at 1.9.10. You can check the main build.gradle file in the root folder of your project.

1) https://libgdx.badlogicgames.com/versions.html
shatterblast
 
Posts: 620
Joined: Sun Jul 06, 2014 1:14 pm

Re: RoboVM plugin is disabled

Postby a11an » Fri Jan 17, 2020 8:58 am

Thanks for your reply. Unfortunately, I don't think it's the version. Currently on 2.3.7 and 1.9.10. I have also tried the later snapshot, no difference. I'm going to completely remove IntelliJ IDEA, remove setting and reinstall, hoping that might solve it!

Code: Select all
allprojects {

    version = '1.0'
    ext {
        appName = "my-gdx-game"
        gdxVersion = '1.9.10'
        roboVMVersion = '2.3.7'
        box2DLightsVersion = '1.4'
        ashleyVersion = '1.7.0'
        aiVersion = '1.8.0'
    }

    repositories {
        mavenLocal()
        mavenCentral()
        jcenter()
        google()
        maven { url "https://oss.sonatype.org/content/repositories/snapshots/" }
        maven { url "https://oss.sonatype.org/content/repositories/releases/" }
    }
}
a11an
 
Posts: 19
Joined: Wed May 18, 2016 12:16 pm
Location: London

Re: RoboVM plugin is disabled

Postby a11an » Fri Jan 17, 2020 10:10 am

Have done a fresh install of IntelliJ IDEA and now I don't see the RoboVM plugin in the bundled plugins. If I attempt to install the RoboVM plugin in the marketplace it fails and the link to the documentation (http://docs.robovm.com) no longer exists :cry: :cry:
a11an
 
Posts: 19
Joined: Wed May 18, 2016 12:16 pm
Location: London

Re: RoboVM plugin is disabled

Postby evilentity » Fri Jan 17, 2020 12:09 pm

That robovm died long time ago. Use this http://robovm.mobidevelop.com/
Looking for a freelancer? PM me!
Check out libgdx discord server!
evilentity
 
Posts: 4867
Joined: Wed Aug 24, 2011 11:37 am

Re: RoboVM plugin is disabled

Postby a11an » Fri Jan 17, 2020 12:43 pm

evilentity wrote:That robovm died long time ago. Use this http://robovm.mobidevelop.com/


Thanks for the link, I installed the plugin manually by downloading the jar on the site above and I now have the RoboVM menu in my fresh install of IntelliJ IDEA.

Building an IPA at the moment :)
a11an
 
Posts: 19
Joined: Wed May 18, 2016 12:16 pm
Location: London

Re: RoboVM plugin is disabled

Postby shatterblast » Fri Jan 17, 2020 2:44 pm

I hope it works well for you.
shatterblast
 
Posts: 620
Joined: Sun Jul 06, 2014 1:14 pm


Return to Libgdx

Who is online

Users browsing this forum: No registered users and 1 guest