scene2d renaming

Sorry to bother everyone with this, but ActorEvent and ActorListener have been renamed to InputEvent and InputListener. It’s more accurate and Mario wanted it, so blame him. Hate emails are sufficient, but showing up in person is always good too.

Another recent change in scene2d is with touchability. It was a boolean, now it is an enum. The values are “enabled”, which means the actor and children get all the events. This is the default. “disabled” means the actor and children don’t get any events. “onlyChildren” means the actor does not get events, but the children do. This last one allows an actor to be transparent to input events, while still letting children receive events. This is the default value used by Table, so can be layered on top of other actors without eating all the input events.

3 thoughts on “scene2d renaming

  1. I think that libgdx continues to improve itself becouse you are not afraid to make right choices even though initially unpopular to better the framework. keep it up

  2. Two ideas for scene2D:
    1) it would be great to have some kind of “finish()” function that would finish all animation (even forever ones) – right now I use “act(1000)” (which won’t finish forever actions) or clearActions (which would stop instead of going to the end),
    2) it would be really great if action in Actor worked like sequence, so you could write:


    The same goes for parallel, forever, repeat and maybe delay. Example: actor.action(parallel(fadeto(1,5), moveto(2,3,5));

    Just some ideas. 🙂

  3. PS. Uhm, parallel already works like that, I forgot, but repeat and forever could really use ability to state a whole sequence.

Leave a Reply

Your email address will not be published.